분류 전체보기
-
[BOJ#2562번] index()카테고리 없음 2023. 6. 18. 22:41
문제 9개의 서로 다른 자연수가 주어질 때, 이들 중 최댓값을 찾고 그 최댓값이 몇 번째 수인지를 구하는 프로그램을 작성하시오. 예를 들어, 서로 다른 9개의 자연수 3, 29, 38, 12, 57, 74, 40, 85, 61 이 주어지면, 이들 중 최댓값은 85이고, 이 값은 8번째 수이다. 입력 첫째 줄부터 아홉 번째 줄까지 한 줄에 하나의 자연수가 주어진다. 주어지는 자연수는 100 보다 작다. 출력 첫째 줄에 최댓값을 출력하고, 둘째 줄에 최댓값이 몇 번째 수인지를 출력한다. 예제 입력 3 29 38 12 57 74 40 85 61 예제 출력 85 8 a=[int(input()) for i in range(9)] print(max(a)) print(a.index(max(a))+1) max(리스트)..
-
[cs231n_review#Lecture 3-1] loss functionsMachine Learning/cs231n 2023. 6. 18. 17:01
there exists some parameter matrix, W which will take this long column vector representing the image pixels, and convert this and give you 10 numbers giving scores for each of the 10 classes in the case of CIFAR-10. Where we kind of had this interpretation where larger values of those scores, so a larger value for the cat class means the classifier thinks that the cat is more likely for that ima..
-
[BOJ#10807번] count(), list(map(int,input().split()))Programming 기초/Coding Test 2023. 6. 17. 22:54
문제 총 N개의 정수가 주어졌을 때, 정수 v가 몇 개인지 구하는 프로그램을 작성하시오. 입력 첫째 줄에 정수의 개수 N(1 ≤ N ≤ 100)이 주어진다. 둘째 줄에는 정수가 공백으로 구분되어져있다. 셋째 줄에는 찾으려고 하는 정수 v가 주어진다. 입력으로 주어지는 정수와 v는 -100보다 크거나 같으며, 100보다 작거나 같다. 출력 첫째 줄에 입력으로 주어진 N개의 정수 중에 v가 몇 개인지 출력한다. 예제 입력 11 1 4 1 2 4 2 4 2 3 4 4 2 예제 출력 3 n = int(input()) array = list(map(int,input().split())) target = int(input()) print(array.count(target))
-
[cs231n_review#Lecture 2-5] Linear Classifier from viewpoint of the template matching approachMachine Learning/cs231n 2023. 6. 17. 18:40
In linear classification, we're going to take a bit of a different approach from k-nearest neighbor. So, the linear classifier is one of the simplest examples of what we call a parametric model. we usually write as X for our input data, and also a set of parameters, or weights, which is usually called W, also sometimes theta, depending on the literature. So, in the k-nearest neighbor setup there..
-
[cs231n_review#Lecture 2-4] Cross-ValidationMachine Learning/cs231n 2023. 6. 16. 19:21
idea # 4 Cross-validation Where your algorithm is able to see the labels of the training set, but for the validation set, your algorithm doesn't have direct access to the labels. We only use the labels of the validation set to check how well our algorithm is doing. (Cross-Validation can alleviates over-fitting problem) these things like Euclidean distance, or L1 distance, are really not a very g..
-
[cs231n_review#Lecture 2-3] Setting HyperparametersMachine Learning/cs231n 2023. 6. 14. 17:36
idea #1 if we use this strategy we'll always pick K=1, in practice it seems that setting K equals to larger values might cause us to misclassify some of the training data, but, in fact, lead to better performance on points that were not in the training data. we don't care about fitting the training data, we really care about how our classifier, or how our method, will perform on unseen data afte..
-
[이코테 # 다이나믹 프로그래밍1] 설명 및 메모이제이션Programming 기초/Coding Test 2023. 6. 13. 23:16
* 다이나믹 프로그래밍기법 동적계획법이라고도 하며, 메모리 공간을 약간 더 사용하여 연산 속도를 비약적으로 증가시키는 방법이다. 다이나믹 프로그래밍이란 큰 문제를 작게 나누고, 같은 문제라면 한 번씩만 풀어 문제를 효율적으로 해결하는 알고리즘 기법이다. 다이나믹 프로그래밍과 분할 정복의 차이점은 다이나믹 프로그래밍은 문제들이 서로 영향을 미치고 있다는 점이다. 아래 두 조건을 만족할 때 다이나믹 프로그래밍을 사용할 수 있다. 재귀 함수를 사용하면 컴퓨터 시스템에서는 함수를 다시 호출했을 때 메모리 상에 적재되는 일련의 과정을 따라야 하므로 오버헤드가 발생할 수 있다. 따라서 재귀 함수 대신에 반복문을 사용하여 오버헤드를 줄일 수 있다. 일반적으로 반복문을 이용한 다이나믹 프로그래밍이 더 성능이 좋다. 1..
-
[cs231n_review#Lecture 2-2] Nearest Neighbor classifierMachine Learning/cs231n 2023. 6. 13. 11:30
you might imagine working on this dataset called CIFAR-10, which is very commonly used in machine learning, as kind of a small test case. the CIFAR-10 dataset gives you 10 different classes, and for each of those 10 categories it provides 50,000 training images, roughly evenly distributed across these 10 categories. And then 10,000 additional testing images that you're supposed to test your algo..